В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Poznavatel01
Poznavatel01
09.02.2020 12:44 •  Информатика

Дан массив a [1 .. 20] целого типа .составить программу замены отрицательных элементов на 0, положительных на 1

Показать ответ
Ответ:
Неко6тян
Неко6тян
03.10.2020 21:22
//Создаем переменные
var  A: array[1..20] of integer;
i: integer;

begin
//Записываем рандомные значения в массив A
for i := 1 to 20 do
A[i] := random(-10, 10); //Указываем границы рандома (от -10 до +10 в данном случае)
//Проверяем числа массива
for i := 1 to 20 do
begin
if A[i] < 0 then A[i] := 0
else A[i] := 1;
end;
{writeln(A);}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота