В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Аннаlove2017
Аннаlove2017
01.07.2022 21:38 •  Информатика

Дан массив а[10]. найти мах элемент среди элементов, стоящих на чётных местах и найденным значением заменить все элементы массива а, кратные 3. преобразованный массив вывести на экран. напишите программу на языке паскаль, !

Показать ответ
Ответ:
Фиалка2332
Фиалка2332
07.10.2020 09:45
Const
  CSize = 10;

var
  m: array[1..CSize] of integer;

begin
  randomize();
  var max := -(MaxInt);
  write('Исходный массив: ');
  for var i := 1 to CSize do
  begin
    m[i] := random(100) + 1;
    if (i mod 2 = 0) and (m[i] > max) then max := m[i];
    write(m[i], ' ')
  end;
  write(NewLine, 'Преобразованный массив: ');
  for var i := 1 to CSize do
  begin
    if m[i] mod 3 = 0 then m[i] := max;
    write(m[i], ' ')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота