Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Kaser3er
20.01.2022 08:38 •
Информатика
Дан массив а(6). найти сумму и количество положительных элементов, расположенных между минимальным и максимальным элементами.
Показать ответ
Ответ:
Stacool220
05.10.2020 07:49
Program example;
const
A=30;
Nmin:=-100; // минимальный параметр
Nmax:=100; //максимальный
var
flag_max : integer;
flag_min : integer;
i. jmin,jmax : integer; //счетчики
Randomize;
array max[A];
//заполняем случайніми числами диапозон -100 +100
for i=1 do A do begin max=:= Random (Nmin + 1) - 2 * Nmax; end;
//ищим максимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_max:=max
jmax:=i; end; else begin flag_max:=max[i+1];
jmax:=i; end; end;
//минимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_min:=max[i+1]
jmin:=i; end; else begin flag_min:=max; jmin:=i; end; end;
//подсчитываем сумму
for i=jmin do jmax-1 do begin max:=max[i+1] end;
//сумма чисел в рандовом массиве между макс и мин єлементом
write('сума',max);
0,0
(0 оценок)
Популярные вопросы: Информатика
яяя489
17.08.2021 11:53
Выполнить значение функции y=kx+b на отрезке [-2; 2] с шагом 2. k и b ввести с клавиатуры. решение с оператором repeat и while. и если не трудно, то блок-схемы....
GALAXY356
06.09.2020 03:58
Сколько цепочек соответствует символам на клавиатуре и каковы их номера? * а)01110101б) 0111110001с) 01010112г) 0101010д) 000001122201...
malinovskaya10102006
15.09.2020 12:15
Используя этот шаблон, реализуйте игры «Камень, ножницы, бумага» и «Угадай число». Правила игры «Камень, ножницы, бумага»: программа запрашивает у пользователя строку и выводит,...
dimas1410
01.04.2022 22:48
Кредит в сумме S млн руб., выданный на n лет под i% годовых, подлежит погашению равными ежегодными выплатами в конце каждого года, включающими процентные платежи и сумму в погашение...
vikap754p08qzb
27.10.2020 11:05
Construct 2 работа с .exe Я хотел спросить на счёт работы с .exe файлами 1:Возможно сделать так что бы скомпелированный проект в Construct 2 мог создавать сторонние exe файлы?...
lphk02
07.05.2020 23:47
Для ввода информации в компьютер можно использовать(клавиатура, процессор, принтер) и (сканер,принтер ,колонки)...
ARTiStlll
08.07.2020 02:48
На конкурсе «кто больше лопнет шариков» юля лопнула больше, чем аня, маша – больше, чем таня, но меньше, чем аня. а катя лопнула меньше тани. расставь девочек от победителя...
prostochel4
24.02.2020 10:04
Написать программу на языке паскаль нахождения всех трехзначных чисел, у которых все цифры различны, а также которые кратны семи не только сами, но и сумма цифр этих чисел....
mastervydy
24.02.2020 10:04
Напишите программу вывода на экран 5 первых четных натуральных чисел .с циклом while...
mike432
08.01.2022 05:41
Вцикле последовательно вводится n целых чисел. найди колличество тех из них которые приделении на 5 остаток 4...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
const
A=30;
Nmin:=-100; // минимальный параметр
Nmax:=100; //максимальный
var
flag_max : integer;
flag_min : integer;
i. jmin,jmax : integer; //счетчики
Randomize;
array max[A];
//заполняем случайніми числами диапозон -100 +100
for i=1 do A do begin max=:= Random (Nmin + 1) - 2 * Nmax; end;
//ищим максимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_max:=max
jmax:=i; end; else begin flag_max:=max[i+1];
jmax:=i; end; end;
//минимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_min:=max[i+1]
jmin:=i; end; else begin flag_min:=max; jmin:=i; end; end;
//подсчитываем сумму
for i=jmin do jmax-1 do begin max:=max[i+1] end;
//сумма чисел в рандовом массиве между макс и мин єлементом
write('сума',max);