В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aki4
aki4
28.12.2021 04:59 •  Информатика

Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n дней. Требуется определить, в какие дни осадков не было.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (0≤ai≤103) — количество осадков в i-й день.

Формат выходных данных
Требуется в одной строке через пробел вывести номера дней, в которые осадков не было.

входные данные
4
100 20 0 318

10
0 0 0 0 0 47 777 66 89 6
выходные данные
3

1 2 3 4 5

Показать ответ
Ответ:
nikitavadimovih
nikitavadimovih
18.03.2021 00:44

#include <sstream>

#include <iostream>

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота