В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DashkaGamayunova
DashkaGamayunova
10.05.2021 22:30 •  Информатика

Дан массив a из n целых чисел. Требуется вывести только элементы, оканчивающиеся нулем.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все числа, оканчивающиеся нулем, в том же порядке, в каком они расположены во входном файле.
входные данные
4
100 -20 4 318

10
-42 70 59 76 21 47 77 66 89 60
выходные данные
100 -20

70 60

Показать ответ
Ответ:
kekys326
kekys326
14.03.2021 21:59

#include <iostream>

using namespace std;

signed main(){

   int n, x;

   cin >> n;

   while(n--){

       cin >> x;

       if(x % 10 == 0)

           cout << x << " ";

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота