Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
1356864
22.11.2022 04:18 •
Информатика
Дан массив a из n элементов. вывести все элементы, значение которых превосходит среднего арифметического элементов массива. язык паскаль.
Показать ответ
Ответ:
Женя8а
13.07.2020 22:14
Program enot;
const n= 5;
Var a: array [1..n] of integer;
c:real;
i,max,s:integer;
begin
for i:= 1 to n do begin
read (a[i]);
s:=s+a[i];
end;
c:=s/n;
for i:= 1 to n do
if a[i]>c then write(a[i], '; ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
pro68
15.01.2020 11:50
Лена скачивает дистрибутив ос linux с зарубежного сайта-репозитория, пользуясь односторонним каналом цифровой передачи данных через телевизионное эфирное вещание, обеспечивающим...
kurbedinovazar
23.01.2023 10:27
короче всем привет если ты взялся за моё ДЗ по информатике то желаю тебе удачи так я так ничего не поняла потому что у меня нету компьютера ладно давай удачи люблю!!6г...
holodovika
27.03.2023 18:01
В какой сфере используется финансовые функции...
irinalera22
25.04.2020 04:40
45 написать программу, которая из последовательности целых чисел находит сумму всех нечётных чисел кратных 7, кол-во чисел не превышает 500, а по модулю не превыш. 255...
gamezarif
09.07.2022 07:51
Когда территория Казахстана и Центральной Азии становится местом расселения племен ариев, индоиранцев? Какой облик был у племен ариев и индоиранцев? В результате чего...
meskov
13.02.2020 03:14
написать контрольную работу...
viking0899
17.05.2023 10:38
Знайдіть суму перших шести членів арифметичної прогресії (а n ), якщо а= 15, d=-3....
nikita2024
29.11.2022 15:08
составить оформление задачи...Масса бочки с водой 29 килограммов. Масса пустой бочки 7кг. Чему равна масса воды?...
Баянсулу11
29.11.2022 15:08
В четырёхугольнике ABCD вписанном в окружность, угол B в два раза больше угла C, а их сумма равна 153°. найдите градусную меру угла D....
Яся00000
29.11.2022 15:08
с домашкой! Задание 1. Перепишите предложения в времени. Обратите внимание на зависимость времени придаточного дополнительного предложения от времени главного. 1 They...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
const n= 5;
Var a: array [1..n] of integer;
c:real;
i,max,s:integer;
begin
for i:= 1 to n do begin
read (a[i]);
s:=s+a[i];
end;
c:=s/n;
for i:= 1 to n do
if a[i]>c then write(a[i], '; ');
end.