В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Desa11
Desa11
05.06.2021 22:15 •  Информатика

Дан массив a(n). определите количество четных элементов с четными индексами, кратных 7. выведите на экран исходный массив и полученное количество.

Показать ответ
Ответ:
alamakarova
alamakarova
06.10.2020 03:03
Const n=10; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if (a[i] mod 2=0)and(a[i] mod 7=0)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
25 29 13 39 9 14 27 16 12 45
k = 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота