В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
привет948
привет948
02.04.2021 22:41 •  Информатика

Дан массив a, содержащий 10 элементов: 0, 6, -1, 0, 24, 0, 9, -2, 1, -2. Индексация элементов начинается с нуля. Определите количество чётных элементов массива a после выполнения следующего фрагмента программы:

Показать ответ
Ответ:
ayazhanbeibit51
ayazhanbeibit51
09.12.2021 10:48

Код программы:

var i, sum, a:integer;

begin

 writeln('Четные числа:');

 for i:= 72 to 134 do begin

   if i mod 2 = 0 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, оканчивающиеся на "3":');

 for i:= 72 to 134 do begin

   if i mod 10 = 3 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, сумма цифр которых меньше 11:');

 for i:= 72 to 134 do begin

   a:= i;

   sum:= 0;

   while a <> 0 do begin

     sum := sum + a mod 10;

     a := a div 10;

   end;

   if sum < 11 then

     write(i, ' ');

 end;

end.

0,0(0 оценок)
Ответ:
ololeg1
ololeg1
30.10.2021 23:18
На первое место можно поставить любую из шести допустимых букв (кроме ийо). На второе место можно поставить любую из шести оставшихся букв (ийо уже можно использовать), на третье – любую из шести оставшихся и т. д. Всего получается 6*6*5*5*3*2*1=5400 вариантов. Но в этих вариантах посчитаны слова, в которых ол стоят рядом, их количество нужно вычесть.
Количество слов с ол можно подсчитать по той же схеме, если считать ол единой буквой. У нас остаётся буквы: Н, Б, Е, ИЙ, причём слово не может начинаться с Й. Количество таких слов равно 6*5*5*3*2*1=900. Всего возможных кодов получается 5400-900=4500.
Ответ: 4500.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота