В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
NiKaEmpty
NiKaEmpty
16.10.2022 20:11 •  Информатика

Дан массив а состоящий из элементов n массив b состоящий из элементов m составить программу которая меняет порядок элементов на обратный (для ввода печати использовать функцию )в с++

Показать ответ
Ответ:
zaharovvlad1337
zaharovvlad1337
07.10.2020 05:24
Сначала вводится N(кол-во эл-в в массиве), потом сам массив a.
Потом вводится M и массив b.
Программа выводит перевернутые массивы a и b
Если будут вопросы пиши к комментариям.

#include <bits/stdc++.h>
using namespace std;
int main(){

int N;
cin >> N;
vector<int> a(N);
for (int i = 0; i < N; i++)
    cin >> a[i];
int M;
cin >> M;
vector<int> b(M);
for (int i = 0; i < M; i++)
    cin >> b[i];
reverse(a.begin(), a.end());
reverse(b.begin(), b.end());
for (int i = 0; i < N; i++)
    cout << a[i] << ' ';
    cout << endl;
for (int i = 0; i < M; i++)
    cout << b[i] << ' ';
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота