В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
натик2017
натик2017
20.02.2020 21:22 •  Информатика

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — построить по нему массив b такого же размера, задающийся следующей формулой: bi=(a2i,2⋅ai,где i — четное число;где i — нечетное число.)

Оба массива нумеруются, начиная с 0 (например, массив a имеет вид a0, a1, a2, ..., an−1).

Формат входных данных
В первой строке входных данных находится натуральное число n — количество элементов массива (n≤500).
Во второй строке вводятся n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.
входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
1 6 9 14

16 40 169744 6 4

Показать ответ
Ответ:
azzzz2
azzzz2
20.08.2021 08:08

program z1;

var a:array [1..20] of integer;

i,s,k:integer;

begin

randomize;

s:=0;

k:=0;

write('Массив: ');

for i:=1 to 20 do

begin

a[i]:=random(90)+10;

if a[i] mod 2 <> 0 then

begin

s:=s+a[i];

k:=k+1

end;

write(a[i],'  ')

end;

writeln;

writeln('Среднее арифметическое нечётных элементов: ',s/k:0:1)

end.

Объяснение:

Задаём значение элемента с random

Проверяем значение элемента на нечётность, если условие истинно, то считаем сумму и количество элементов

Выводим  значение элемента на экран

Выводим среднее арифметическое (результат деления суммы на количество) нечётных элементов

0,0(0 оценок)
Ответ:
plkg
plkg
07.10.2022 12:00

Ақпараттық технологиялар саласы негізінен екі тәуелсіз циклде дамиды: өнімділік және қаржылық. Жақында біз қаржылық циклде екендігіміз туралы көптеген даулар болды; қаржылық нарықтарға көп көңіл бөлінеді, олар кейде өзін болжай алмайтындай ұстайды және қатты өзгеріп отырады. Екінші жағынан, өнімнің циклдеріне онша назар аударылмайды, дегенмен олар ақпараттық технологияны алға жетелейді. Бірақ өткен тәжірибені талдай отырып, сіз қазіргі өнім циклын түсінуге және технологиялардың болашақ дамуын болжауға тырыса аласыз. Жоғары технологиялар саласындағы өнім циклдарының дамуы платформалар мен қосымшалардың өзара әрекеттесуі арқылы жүреді: жаңа платформалар жаңа қосымшаларды құруға мүмкіндік береді, бұл өз кезегінде осы платформалардың құнын арттырады, осылайша оң кері байланыс циклін жабады. Шағын өнім циклдары үнемі қайталанып отырады, бірақ тарихи түрде 10-15 жылда бір рет тағы бір үлкен цикл басталатындай дамыды - бұл АТ-ны толық өзгертетін дәуір.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота