В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Gaxling
Gaxling
07.02.2021 10:34 •  Информатика

Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[0]… A[i]). Верните массив с текущей суммой чисел. Текущая сумма получается следующим образом: Массив A состоит из элементов 1,2,3,4. Результат суммирования А = 1,3,6,10. То есть 1, 1+2 (3), 1+2+3 (6), 1+2+3+4 (10). Входные данные В единственной строке входного файла INPUT записан массив А из целых чисел 1 <=Длина массива <= 1000. Элементы массива -10^6 <= А[i] <= 10^6. Выходные данные В единственную строку выходного файла OUTPUT нужно вывести массив А удовлетворяющий условию.


Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[

Показать ответ
Ответ:
SolekProAwp
SolekProAwp
03.12.2020 10:45

N = input().split(',')

arr = []

arr2 = []

for i in N:

   i = int(i)

   n = sum(arr2) + i

   arr2.append(i)

   arr.append(n)

print(arr)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота