В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
narutogovno
narutogovno
10.07.2021 21:19 •  Информатика

Дан массив из 10 целых чисел. написать программу нахождения суммы положительных элементов массива паскаль

Показать ответ
Ответ:
dimas194
dimas194
05.08.2020 14:36

var  

 mas: array[1..10] of integer;

 i, sum: integer;

begin

 sum:=0;

 for i:=1 to 10 do

   begin

 write(i, ' элемент массива: ');

 readln(mas[i]);

 if mas[i] > 0 then

   sum:=sum+mas[i];

   end;

   writeln('Сумма положительных элементов массива: ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота