В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kireezy
Kireezy
14.12.2022 15:05 •  Информатика

Дан массив из 10 целых чисел. определите, сколько элементов этого массива имеют максимальное значение. надо написать на паскале, объяснить при этом всё, ещё и блок схему надо

Показать ответ
Ответ:
3Таня22811
3Таня22811
08.09.2020 17:54
Var m:array[1..10] of integer; i,max,cnt:integer;
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
0,0(0 оценок)
Ответ:
svetlana196420
svetlana196420
08.09.2020 17:54
Var m:array[1..10] of integer; i,max,cnt:integer;
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота