В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ягрь
Ягрь
08.11.2020 07:05 •  Информатика

Дан массив из 10 элементов. составить программу которая даёт ответ на вопрос есть ли в массиве более одного элемента равного максимальному. ответ выводится в виде да/нет. pascal.

Показать ответ
Ответ:
alinalisnenko
alinalisnenko
07.10.2020 10:28
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,9); a.Println;
  if a.Where(t->t=a.Max).Count>1 then
    Writeln('Есть элементы, равные максимальному')
  else
    Writeln('Нет элементов, равных максимальному')
end.

Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному

1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота