Дан массив из 19 целых чисел заполненный случайными числами из интервала [-64; 7].
1. Выведите этот массив в строку и найдите количество нечетных, отрицательных элементов массива, которые меньше 3.
2. Найдите минимальный элемент в массиве.
3. Выполнить сортировку массива по возрастанию.
В паскале.
program raf105;
var
a,b: array[1..7] of integer;
i,x,win: integer;
begin
writeln('Добро в игру "Лотерея"!');
write('Введите семизначное число: ');
readln(x);
writeln;
a[1]:= x div 1000000;
a[2]:= (x div 100000) mod 10;
a[3]:= (x div 10000) mod 10;
a[4]:= (x div 1000) mod 10;
a[5]:= (x div 100) mod 10;
a[6]:= (x div 10) mod 10;
a[7]:= x mod 10;
x:= random(1000000,9999999);
b[1]:= x div 1000000;
b[2]:= (x div 100000) mod 10;
b[3]:= (x div 10000) mod 10;
b[4]:= (x div 1000) mod 10;
b[5]:= (x div 100) mod 10;
b[6]:= (x div 10) mod 10;
for i:=1 to 7 do
if a[i] = b[i]
then if win <> 0
then win:= win*10
else win:= 1;
writeln('Ваш выигрыш ',win,' руб.');
write('Введённые числа: ');
for i:=1 to 7 do
write(a[i],' ');
writeln;
write('Сгенерированные числа: ');
for i:=1 to 7 do
write(b[i],' ');
end.
PascalABC 3.4.2следите за исправностью аппаратуры и немедленно прекращайте работу при появлении необычного звука или самопроизвольного отключения аппаратуры;
легко и быстро нажимайте на клавиши, не допуская резких ударов;
не пользуйтесь клавиатурой и мышью, если не включен компьютер;
работайте на клавиатуре чистыми руками;
никогда не пытайтесь самостоятельно устранить неисправность в работе аппаратуры;
не вставайте со своих рабочих мест, когда в кабинет входят посетители.