В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alenakoryakovaa
alenakoryakovaa
27.03.2023 03:12 •  Информатика

Дан массив из 20 целых чисел. Элементы массива вводятся с клавиатуры. В данном массиве найдите количество чисел, соседи у которых отличаются более чем на 2 (первый и последний элементы не берутся) Решение должно быть выполнено через процедуру.

Показать ответ
Ответ:
Лиза18511
Лиза18511
26.07.2021 22:42
Держи. Программа написана для PascaABC.net.
Что бы изменить количество массива - измени значение в графе const в самом верху программы. Первый отрезок программы (до пустой строчки) - заполнение и вывод массива из случайный значений из промежутка [a,b].
Вторая часть программы(в серединке) нахождение таких элементов массива, которые удовлетворяют условиям задачи - т.к. локальный минимум - в занос индексов этих элементов в новый массив d.
Последняя строчка - вывод ответ, если массив с индексами пустой - напишет "не найдено" , а если такие элементы есть, то выведет все индексы на экран.
Напишите программу, которая заполняет массив случайными числами в диапазоне [a, b], выводит его на э
0,0(0 оценок)
Ответ:
1ПИНЧЕР1
1ПИНЧЕР1
31.01.2023 06:31
Не совсем понимаю вопроса.
div - это целое значения после деления одного числа на другое
mod - это остаток от деления одного числа на другое
т.е. например 
a:=7 div 2;
a=3
b:=7 mod 2;
b=1
Примеры использования div и mod могут быть разные. Например их можно использовать для деления числа на отдельные цифры. Так остаток от деления на 10 (a mod 10) даст нам последнюю цифру. А если для трёхзначного числа зададим (a div 100) то найдём его первую цифру. Так же для нахождения средней цифры в трёхзначном числе можно написать как ((a mod 100)div 10) так и  ((a div 10)mod 10). 
Так же с можно находить количество цифр в числе, и программа будет выглядеть так:
var i:byte; a,k:integer;
a:=4873; k:=0;
while a>0 do begin
k:=k+1;
a:=a mod 10;
end;
writeln(k);
end. 
Знаем что такое двоичная система? Так вот с и mod можно написать программу перевода числа в двоичную систему, или просто подсчитать количество нулей и единиц в двоичной записи числа. Подсчёт единиц и нулей выглядит так:
var a,b,c:integer;
a:=34;b:=0;c:=0;
while a>0 do begin
if a mod 2=0 then b:=b+1 else c:=c+1;
a:=a mod 10;
end;
writeln('количество нулей=',b);
writeln('количество единиц=',c);
end.
Вообще много чего можно придумать. Узнать чётное ли число(mod), узнать количество чётных и нечётных цифр в числе(mod), узнать сколько раз число a делиться на число b(mod и div). 
Так div и mod можно использовать где угодно и как угодно, и всё зависит от фантазии человека который пишет программу. Единственное что надо помнить, что mod и real выполняются для чисел integer, и если мы попытаемся исполнить операции для real (например 3,4 или 6,7) то наткнёмся на ошибку. Ну а так же, чисто из математики, мы не можем делить на ноль, следственно (a div 0) тоже операция не выполнима так же как и (a mod 0) .
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота