В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gavrikovakateri
gavrikovakateri
08.03.2023 08:40 •  Информатика

Дан массив из 5 элементов. найти второе положительное число. (написать программу на языке бейсик)

Показать ответ
Ответ:
worldteawithlemon
worldteawithlemon
05.10.2022 11:00

5,25 Мб

Объяснение:

Поскольку разрешение состоит из двух сомножителей - ширины и высоты, то при уменьшении разрешения в 4 раза количество пикселей уменьшится в 4*4=16 раз.

Формула объема файла изображения

V = N*i, где N — общее количество пикселей, а i — глубина цвета (количество бит, выделенное на 1 пиксель)

Составим систему уравнений.

Для первого файла имеем

42=N*i

Для второго файла:

V = N/16 * 2i

Выражаем N в первом уравнении

N=42/i

Подставляем во второе уравнение:

V=42/i :16 *2i

V=42/16i *2i

V=42/8=5,25 Мб

0,0(0 оценок)
Ответ:
anokhina69
anokhina69
22.11.2020 20:14

(см. объяснение)

Объяснение:

Решение на PascalABC.NET:

##

var a: BigInteger := BigInteger.Subtract(BigInteger.Subtract(BigInteger.Multiply(BigInteger.Parse('3'), BigInteger.Pow(BigInteger.Parse('2'), 32)), BigInteger.Pow(BigInteger.Parse('2'), 10)), BigInteger.Parse('3'));

var b: String;

while(a>0) do

begin

 b:= BigInteger.Remainder(a, 4).ToString+b;

 a:= BigInteger.Divide(a, 4);

end;

print(b.Count(x->x='3'));

Решение на Python3:

a = 3 * 2 ** 32 - 2 ** 10 - 3

b = ''

while a > 0:

   b = str(a % 4) + b

   a //= 4

print(b.count('3'))

Решение на Java:

import java.math.BigInteger;

public class Study

{

public static void main(String[] args)

{

System.out.println(BigInteger.valueOf(3L).multiply(BigInteger.valueOf(2L).pow(32)).subtract(BigInteger.valueOf(2L).pow(10)).subtract(BigInteger.valueOf(3L)).toString(4).chars().filter(x->x=='3').count());

}

}

Результатом работы программ во всех случаях будет одно число 14.

Задание выполнено!

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота