В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lyagaeva87
lyagaeva87
18.04.2021 00:28 •  Информатика

Дан массив из 50 элементов. каждый элемент может принимать целочисленное значение от -500 до 500. напишите программу, которая определяет на сколько число положительных элементов массива больше, чем число отрицательных, и выведите найденное значение. гарантируется, что в исходном массиве есть и отрицательные, и положительные элементы, и положительных элементов больше.

Показать ответ
Ответ:
ruuuuuyslan
ruuuuuyslan
11.10.2020 03:22

Объяснение:

program ArrayOf50;

const

   ArraySize = 50; {Определяем размен массива}

   

var

   x: array[1..ArraySize] of integer;

   i, PosCount, NegCount : integer;

   

begin

   PosCount :=0; NegCount :=0; {Устанавливаем счетчики пол. и отр. чисел}

   for i:=1 to ArraySize do begin {Цикл ввода данных}

       Write('Input ', i, '-th element of array: ');

       ReadLn(x[i]);

   end;

   for i:=1 to ArraySize do begin {Цикл обработки данных}

       if x[i] > 0 then PosCount := PosCount+1; {считаем положительные}

       if x[i] < 0 then NegCount := NegCount+1; {считаем отрицательные, нули в расчет не берутся!}

   end;

   Writeln('There are ', PosCount, ' positive numbers.');

   Writeln('This is ', PosCount - NegCount, ' more than negatives');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота