В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mashaaa98
mashaaa98
13.11.2020 04:08 •  Информатика

Дан массив из 8 целых чисел. составить программу вычисления суммы элементов массива меьнших 10

Показать ответ
Ответ:
Asil1231
Asil1231
11.09.2020 16:25

var a: array[1..8] of integer;

i,s: integer;

begin

randomize;

s:=0;

write('массив: ');

for i:=1 to 8 do begin

a[i]:=random(41)-20;

if a[i]<10 then s:=s+a[i];

write(a[i],' ');

end;

writeln;

write('сумма: ',s);

end.


Дан массив из 8 целых чисел. составить программу вычисления суммы элементов массива меьнших 10
0,0(0 оценок)
Ответ:
nifirazifira
nifirazifira
11.09.2020 16:25

PascalABC.NET

begin

 var a := ArrRandom(8, -20, 20);

 a.Println;

 a.Where(p -> p < 10).Sum.Println

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота