Дан массив из n чисел. пользователь вводит индекс числа и само число. и надо вставить это число. допустим массив 1 2 3 4 5 6 7 8 9 10 пользователь ввел индекс 3 и число 6 массив должен получиться таким 1 2 6 3 4 5 6 7 8 9 10. напишите программу на паскале
n = 10;
var
T: array[1..n + 1] of integer;
i, j, k: integer;
begin
Writeln('Введите ', n, ' элементов массива');
for i := 1 to n do Read(T[i]);
Write('Укажите индекс числа и само число для вставки: ');
Readln(j, k);
for i := n downto j do T[i + 1] := T[i];
T[j] := k;
Writeln('Результирующий массив:');
for i := 1 to n + 1 do Write(T[i], ' ')
end.
Тестовое решение:
Введите 10 элементов массива
-5 3 12 81 35 0 43 92 -23 53
Укажите индекс числа и само число для вставки: 4 777
Результирующий массив:
-5 3 12 777 81 35 0 43 92 -23 53