В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
enotnana
enotnana
19.08.2020 00:31 •  Информатика

Дан массив из n элементов. составить программу , сортирующую по возрастанию все числа с нечётными индексами в массиве.

Показать ответ
Ответ:
точно2
точно2
01.10.2020 13:59
var
  a: array [1..100] of integer;
  i,j,n,k: integer;

begin
  readln(n);
  for i:= 1 to n do readln(a[i]);
  for i:= 1 to n do if Odd(i) then
    for j:= 1 to n-i do if Odd(j) then
      if a[j]>a[j+2] then begin
        k:= a[j];
        a[j]:= a[j+2];
        a[j+2]:= k
      end;
  for i:= 1 to n do write(a[i],' ')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота