В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Дан массив, содержащий 30 целых чисел. Составьте программу, позволяющую найти и вывести наибольшее содержащееся в массиве трехзначное положительное число, десятичная запись которого оканчивается цифрой 3. Если ни одного такого числа нет, нужно вывести сообщение. Язык программирования python. (За раннее огромное и пять звезд))

Показать ответ
Ответ:
olgafajzulloev
olgafajzulloev
01.04.2023 09:12
Python

n = int(input())

s = []

result = [0,0,0]

for i in range(n):

   k = int(input())

   while not (-10000 < k < 10000):

       k = int(input("Out of range. Repeat: "))

   s.append(k)

for i in s:

   if i > 0:

       result[0] += 1

   elif i < 0:

       result[1] += 1

   elif i == 0:

       result[2] += 1

for i in result:

   print(i, end=" ")

Ввод/Вывод:

5                                                                                                                                

3                                                                                                                                

4                                                                                                                                

-4                                                                                                                              

-2                                                                                                                              

0                                                                                                                                

2 2 1

0,0(0 оценок)
Ответ:
olyatko1984
olyatko1984
12.03.2023 01:14

использовать Чертежник

алг

нач

цел в, г

вывод "Введите количество повторов по вертикали: "

ввод в

вывод "Введите количество повторов по горизонтали: "

ввод г

нц в раз

нц г раз

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-1,0)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,1)

сместиться на вектор (1,0)

сместиться на вектор (1,-1)

сместиться на вектор (0,-1)

сместиться на вектор (-1,-1)

сместиться на вектор (-1,0)

сместиться на вектор (-1,1)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (2,2)

сместиться на вектор (1,0)

сместиться на вектор (2,-2)

сместиться на вектор (0,-1)

сместиться на вектор (-2,-2)

сместиться на вектор (-1,0)

сместиться на вектор (-2,2)

поднять перо

сместиться на вектор (5,0)

кц

сместиться на вектор (-(г*3),-3)

кц

кон

Объяснение:

картинка


3. Составьте программу рисования узора, показанного на рисунке. Количество повторений элементов узор
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота