В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
чибик228
чибик228
13.05.2023 08:09 •  Информатика

Дан массив, состоящий из целых чисел. нумерация элементов начинается с 0. напишите программу, которая выведет элементы массива, номера которых четнывходные данныезадано число n — количество элементов в массиве (1=

Показать ответ
Ответ:
0987mnbv
0987mnbv
20.12.2022 14:36
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Ответ:
zhannursadykbek
zhannursadykbek
02.08.2021 22:09
Program Number;
var  x: integer; { введенное число }  n: byte := 0; { количество цифр в числе }  i, j: byte; { счетчики }  xi: array[1..5] of integer;{массив цифр, из которых состоит число}
begin  { Ввод исходного числа }  readln(x);  writeln;   x := abs(x); // рассматриваем модуль числа  { Разбиение числа на цифры }  while (x > 0) do  begin    n := n + 1; // увеличиваем количество цифр    xi[n] := x mod 10; // вычисляем цифру (остаток от деления на 10)    if xi[n] = 8 then // если встретилась 8,    begin      writeln('да'); // то число "бесконечное"      readln;      exit;          // выход из программы    end;    x := x div 10; // изменяем число (целое от деления на 10)  end;  { Поиск цифр, встречающихся больше одного раза}  for i := 1 to n - 1 do    for j := i + 1 to n do      if xi[i] = xi[j] then // если числа      begin        writeln('да'); // то число "бесконечное"        readln;        exit;  // выход из программы       end;  { Число не явлется "бесконечным" }  writeln('нет');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота