В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Саша030612
Саша030612
09.05.2022 23:59 •  Информатика

Дан одномерный целочисленный массив A[15]. Элементы массива вводятся с
клавиатуры. Написать программу, которая будет находить сумму положительных
элементов массива, стоящих на нечетных местах.

Показать ответ
Ответ:
Батаева095
Батаева095
30.07.2020 13:05

var A: array [1..15] of integer;

var i,s: integer;

begin

s:=0;

for i:=1 to 15 do

 begin  

 read(A[i]);

 if (A[i]>0) and (i mod 2 <>0) then s:=s+A[i];

 end;

writeln('Сумма положительных',

' элементов массива, стоящих на нечетных местах: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота