Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Математик094
05.05.2022 11:26 •
Информатика
Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым
Показать ответ
Ответ:
Temik763
03.10.2020 03:17
// PascalABC.NET 3.0, сборка 1111
begin
var a:=ArrRandom(10,-15,25);
Write('Исходный массив: '); a.Println(',');
Writeln('Сумма min+max=',a.Min+a.Max)
end.
Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
0,0
(0 оценок)
Ответ:
1Max8
03.10.2020 03:17
Program Project1;
var i, max, min:integer; mass:array [0..9] of integer;
begin
randomize;
for i:=1 to 9 do mass[i]:=Random(100);
max:=0;
min:=100;
for i:=1 to 9 do begin
if max<mass[i] then max:=mass[i];
if min>mass[i] then min:=mass[i];
end;
writeln('max: ', max);
writeln('min: ', min);
writeln('max + min = ', max+min);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
DemEntrA132
07.01.2023 21:44
Для переименования рабочего листа можно (укажите все правильные варианты): щелкнуть на нем левой кнопкой мыши и из контекстного меню выбрать пункт переименовать изменить...
Laki333
05.06.2020 17:15
Какие множества можно задавать перечислением всех элементов?...
Мика7477u
21.03.2021 08:45
с заданием по информатике1. Ситуация. Вы отправили в магазин деда-инженера. Он вместо батона, купил топор. Подумайте, почему так произошло и что мы не учли при постановке...
chiginavera
28.12.2020 13:49
Файл размером 7мбайт передается через некоторое соединение за 28 секунд.определите размер файла (в кбайт),который можно передать через другое соединение с вдвое большей скоростью...
tri0
30.07.2020 00:42
Построить цепочки интервалов и...
elizabethniall
13.04.2020 17:26
Lq=42° lm=61° найдите внешний угол....
Dorefi
31.01.2020 03:42
Чем похожи отец и сын дубровские...
123настюша321
06.09.2020 17:25
2целых 1\3 : -7 две целых одна третья делится на минус семь...
angelinashushi
22.08.2022 02:24
Вывод образования казахского ханства...
turysbekaida
22.08.2022 02:24
Два водолаза находятся в море на одной и той же глубине. один из водолазов находится на дне под открытой поверхностью воды, а другой – на той же глубине в подводной пещере....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var a:=ArrRandom(10,-15,25);
Write('Исходный массив: '); a.Println(',');
Writeln('Сумма min+max=',a.Min+a.Max)
end.
Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
var i, max, min:integer; mass:array [0..9] of integer;
begin
randomize;
for i:=1 to 9 do mass[i]:=Random(100);
max:=0;
min:=100;
for i:=1 to 9 do begin
if max<mass[i] then max:=mass[i];
if min>mass[i] then min:=mass[i];
end;
writeln('max: ', max);
writeln('min: ', min);
writeln('max + min = ', max+min);
end.