Дан одномерный массив размером N, заменить элементы, имеющие дробную часть на нули. Напишите программу на языке Паскаль для работы с одномерным массивом.
Пусть a,b,c - стороны треугольника (и их длины). Условие существование треугольника:
Пусть а - наибольшая из сторон, тогда против нее будет лежать наибольший угол, который можно определить по теореме косинусов:
Текст программы приводится ниже. var a,b,c,t,cosA:real; begin Write('Введите длины сторон треугольника: '); Readln(a,b,c); if (a<b+c) and (b<a+c) and (c<a+b) then begin if a>b then begin if a<c then begin t:=a; a:=c; c:=t end end else if b>c then begin t:=a; a:=b; b:=t end else begin t:=a; a:=c; c:=t end; cosA:=(sqr(c)+sqr(b)-sqr(a))/(2*b*c); if cosA=0 then Writeln('Треугольник прямоугольный') else if cosA<0 then Writeln('Треугольник тупоугольный') else Writeln('Треугольник остроугольный') end else Writeln('Треугольник построить нельзя') end.
Тестовое решение: Введите длины сторон треугольника: 4 6.1 3.7 Треугольник тупоугольный
информатика – современная область знаний. мы изучаем ее в школе, как предмет, но не только. зачем нужна информатика? в современном мире мы каждый день сталкиваемся с новейшими технологиями. у меня дома есть компьютер, подключенный к интернету. когда я ищу что-нибудь в интернете или пишу другу сообщение, то использую достижения информатики.
вокруг нас – море информации, а наука информатика как раз решает вопросы, как этим морем. поэтому она и носит такое название. без достижений информатики не существовало бы компьютеров, интернета и других новых технологий, которые уже стали для нас привычны. не было бы даже вычислительных машин, которые могут производить сложные расчеты за доли секунды. а расчеты нужны везде: на производстве, в банках, на линиях транспорта. жизнь была бы намного сложнее, если бы информатика не развилась до такого уровня, как сейчас.
не было бы поисковых систем, с которых сейчас можно отыскать нужны информацию. я не говорю, что можно найти любую информацию о любом человеке, потому что в мире всегда остаются тайны и секреты. но большинство информации, полезной в учебе и повседневной жизни, найти можно. ну, и море всякого интересного тоже. еще лет двадцать назад для этого пришлось бы идти в библиотеку и рыться там полдня.
возникает вопр�с, зачем изучать информатику всем школьникам? ведь далеко не все станут программистами, системными администраторами, веб-дизайнерами? наверное, смысл этого в том, чтобы все понимали, с чем они сталкиваются каждый день, как это действует. ведь не зря наше время называется информационной эпохой.
Пусть а - наибольшая из сторон, тогда против нее будет лежать наибольший угол, который можно определить по теореме косинусов:
Текст программы приводится ниже.
var
a,b,c,t,cosA:real;
begin
Write('Введите длины сторон треугольника: '); Readln(a,b,c);
if (a<b+c) and (b<a+c) and (c<a+b) then
begin
if a>b then
begin
if a<c then begin t:=a; a:=c; c:=t end
end
else
if b>c then begin t:=a; a:=b; b:=t end
else begin t:=a; a:=c; c:=t end;
cosA:=(sqr(c)+sqr(b)-sqr(a))/(2*b*c);
if cosA=0 then Writeln('Треугольник прямоугольный')
else
if cosA<0 then Writeln('Треугольник тупоугольный')
else Writeln('Треугольник остроугольный')
end
else
Writeln('Треугольник построить нельзя')
end.
Тестовое решение:
Введите длины сторон треугольника: 4 6.1 3.7
Треугольник тупоугольный
сочинение на тему «информатика в нашей жизни»
информатика – современная область знаний. мы изучаем ее в школе, как предмет, но не только. зачем нужна информатика? в современном мире мы каждый день сталкиваемся с новейшими технологиями. у меня дома есть компьютер, подключенный к интернету. когда я ищу что-нибудь в интернете или пишу другу сообщение, то использую достижения информатики.
вокруг нас – море информации, а наука информатика как раз решает вопросы, как этим морем. поэтому она и носит такое название. без достижений информатики не существовало бы компьютеров, интернета и других новых технологий, которые уже стали для нас привычны. не было бы даже вычислительных машин, которые могут производить сложные расчеты за доли секунды. а расчеты нужны везде: на производстве, в банках, на линиях транспорта. жизнь была бы намного сложнее, если бы информатика не развилась до такого уровня, как сейчас.
не было бы поисковых систем, с которых сейчас можно отыскать нужны информацию. я не говорю, что можно найти любую информацию о любом человеке, потому что в мире всегда остаются тайны и секреты. но большинство информации, полезной в учебе и повседневной жизни, найти можно. ну, и море всякого интересного тоже. еще лет двадцать назад для этого пришлось бы идти в библиотеку и рыться там полдня.
возникает вопр�с, зачем изучать информатику всем школьникам? ведь далеко не все станут программистами, системными администраторами, веб-дизайнерами? наверное, смысл этого в том, чтобы все понимали, с чем они сталкиваются каждый день, как это действует. ведь не зря наше время называется информационной эпохой.