В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Diagramma1
Diagramma1
06.09.2021 16:37 •  Информатика

Дан символьный массив а[n][n]. найти все такие целые числа k, что k-я строка матрицы совпадает с k-м столбцом. написать программу на с++

Показать ответ
Ответ:
cheburek20
cheburek20
09.10.2020 14:36

#include <bits/stdc++.h>

using namespace std;

int a[1010][1010],n;

bool sovp(int x) {

for (int i = 1; i <= n; i++)

 if (a[x][i] != a[i][x]) return 0;

return 1;

}

main () {

cin >>n;

for (int i = 1; i <= n; i++)

 for (int j = 1; j <= n; j++)

  cin >>a[i][j];

for (int i = 1; i <= n; i++)

{

 if (sovp(i) == 1) cout <<i <<" ";

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота