В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ardolg
ardolg
04.07.2020 08:30 •  Информатика

дан список чисел. Напишите программу выводящую на экран числа которые больше предыдущих

Показать ответ
Ответ:
малышка172
малышка172
14.06.2021 12:07

def sqc(xa,ya,xb,yb,xc,yc) :

   return ((xb - xa) * (yc - ya) - (xc - xa) * (yb - ya)) / 2

 

xa, ya, xb, yb = map(float,input().split())

n, m = map(int,input().split())

astra = []

sc  = []

res, smax = 0, 0

for i in range(n) :

   xc, yc = map(float,input().split())

   astra.append((xc,yc))

   sctmp = sqc(xa,ya,xb,yb,xc,yc)

   if smax < abs(sctmp) :

       smax = abs(sctmp)

   #print(sctmp)

   sc.append(sctmp)

for i in range(m) :

   xc, yc = map(float,input().split())

   sp = sqc(xa,ya,xb,yb,xc,yc)

   if smax < abs(sp) :

       smax = abs(sp)

   #print(sp)

   for j in range(n) :

       xd, yd = astra[j][0], astra[j][1]

       if sp * sc[j] < 0 :

           if smax < abs(sp * sc[j]) :

               smax = abs(sp * sc[j])

print('{:.2f}'.format(smax))

У меня получилось.

0,0(0 оценок)
Ответ:
MashaBendyuk
MashaBendyuk
14.06.2021 12:07

Объяснение:

1. • мышь • клавиатура • экран дисплея.

2. • графический дисплей

3. • пикселем.

4. растром.

5.  фрактальной & растровой

6. совокупность трех зерен люминофора.

7. Устройство, управляющее работой графического дисплея.

8. Электронное, энергозависимое устройство для хранения двоичного кода изображения, выводимого на экран.

9. 256 битов

10. Принтер.

11. 2 раза

12. Векторной.

13. сокращает объем памяти, необходимой для хранения изображения, и облегчает редактирование последнего

Объяснение:

1. (Если надо один ответ, то клавиатура)  

3. Почему? ответ: на всех остальных делает машина, а тут саморучно

11. Что бы доказать для представления 65536 цветов требуется 16 чисел (00010000000000000000), а для 256 цветов - 8 (000100000000). 16 / 8 = 2.

Дальше не знаю

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота