В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
максим885б
максим885б
28.12.2020 21:55 •  Информатика

Дан текстовый файл. составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. вставьте в конце каждой строки количество слов и записать в новом файле.

Показать ответ
Ответ:
Deliya2000
Deliya2000
18.09.2020 10:19
Var  s          : string;  finish,k,i : longint;begin  assign(input,'input.txt'); reset(input);  assign(output,'output.txt'); rewrite(output);  finish:=0;  while(finish=0) do { если finish будет <> 0 то программа    перестанет читать текст}    begin      writeln('читать? если да, то 0 если нет, то 1');      readln(finish);      k:=0;      if finish=0        then begin               readln(s);               for i:=1 to length(s) do                 if s[i]=' '                   then inc(k);             end        else exit;      inc(k);      writeln(k);    end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота