Дана блок-схема алгоритма обработки целочисленного массива A из 10 элементов. Чему будет равна переменная cnt после завершения работы алгоритма, если изначально: A = {1, 2, 8, 2, 3, 6, 2, 4, 2, 2}. Индексация элементов массива начинается с 1. В ответе укажите число.
var
t:boolean;
d:integer;
begin
t := true;
d := 2;
while t and (d*d <= x) do
begin
if x mod d = 0 then
t := false;
d := d + 1
end;
prime := t
end;
function order(x:integer):boolean;
var
t:boolean;
d:integer;
begin
d := -1;
repeat
t := x mod 10 > d;
d := x mod 10;
x := x div 10
until not t or (x = 0);
order := t
end;
var
t:boolean;
i,k,n:integer;
begin
t := false;
read(k,n);
for i := k to n do
if prime(i) then
if order(i) then
begin
write(i,' ');
t := true
end;
if not t then
write(0)
end.
Технология мультимедиа положена в основу создания всевозможных мультимедийных продуктов, характерными особенностями которых являются:
- объединение в одном продукте текстовой, графической, аудио-, видеоинформации, анимаций;
- наличие интерактивного (диалогового) режима работы;
- возможность быстрого поиска информации;
- широкие возможности навигаций;
- возможность работы в реальном времени, в замедленном или в ускоренном темпе;
- дружественный пользовательский интерфейс.
Например, в компьютерной игре задействованы графика и аудиоинформация.