В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anyanice7
anyanice7
29.11.2020 15:25 •  Информатика

Дана блок-схема алгоритма обработки целочисленного массива A из 8 элементов. Индексация элементов массива начинается с 1. Оператор mod обозначает остаток от деления. Чему будет равна переменная cnt после завершения работы алгоритма, если A = { 9, 7, 5, 6, 4, 6, 5, 8 }.

В ответе укажите число.


Дана блок-схема алгоритма обработки целочисленного массива A из 8 элементов. Индексация элементов ма

Показать ответ
Ответ:
Foxer30
Foxer30
21.06.2021 13:20
1)program test;
var
  a:array[1..12] of integer;
  i,min:integer;
begin
  for i:=1 to 12 do begin
    readln(a[i]);
    a[i]:=abs(a[i]);
    if i=1 then min:=a[i]
    else if a[i]<min then min:=a[i];
  end;
  writeln(min);
end.
2)
uses Crt ;
var
   A            : array [ 1 .. 100 ] of integer ;
   c            : integer ;
   i , j , N    : ShortInt ;
begin
     ClrScr ;
     Write ( 'Количество элементов массива = ' ) ;
     ReadLn ( N ) ;
     WriteLn ( 'Ввод массива' ) ;
     for i := 1 to N do
         Read ( A [ i ] ) ;
        
         A[i]:=abs(A[i]);
     WriteLn ;
     //Сортировка пузырьком//
     for i := 1 to N - 1 do begin
         for j := N downto i + 1 do begin
             if A [ j ] < A [ j - 1 ]
             then
             begin
                  c := A [ j ] ; A [ j ] := A [ j - 1 ] ; A [ j - 1 ] := c ;
             end ;
            
         end;
        
     end;
     for i:=n-2 to n do writeln(A[i]);
end .
0,0(0 оценок)
Ответ:
Как то так, можешь заменить так что бы ракета вверх двигалась.
Program raketa;
uses graphabc;
var i:integer;
begin
For i:=1 to 300 do begin
line (i+300,60,i+240,120);
line (i+240,120,i+240,360);
line (i+360,120,i+360,360);
line (i+240,360,i+360,360);
line (i+300,60,i+360,120);
line (i+240,210,i+210,240);
line (i+210,240,i+240,240);
line (i+360,210,i+390,240);
line (i+390,240,i+360,240);
circle (i+300,150,15);
circle (i+300,210,15);
circle (i+300,270,15);
line (i+240,360,i+180,450);
line (i+180,450,i+420,450);
line (i+420,450,i+360,360);
line (i+330,450,i+330,370);
line (i+300,450,i+300,365);
line (i+270,450,i+270,370);
ClearWindow;
end;
end.
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота