В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alinasupieva0910
alinasupieva0910
14.05.2022 08:07 •  Информатика

Дана матрица А(nxn). Написать программу, которая упорядочивает элементы каждого столбца этой матрицы по убыванию написать программу на С++, заранее

Показать ответ
Ответ:
MarinaRaim26
MarinaRaim26
08.11.2021 15:20
Const dN=-2; dK=1; Hd=0.5; tN=-1; tK=-3; Ht=-1;
var d,t,z:real; i,j,n1,n2:integer;
begin
n1:=round((dK-dN)/Hd);
n2:=round((tK-tN)/Ht);
d:=dN-Hd;
writeln(' d     t    z');
for i:=0 to n1 do
 begin
 d:=d+Hd;
 t:=tN-Ht;
 for j:=0 to n2 do
  begin
  t:=t+Ht;
  z:=sqrt(abs(d*d*d-2))+3*t;
  writeln(d:4:1,' ',t:4:1,' ',z:6:3);
  end;
 end;
end.

Результат:
 d     t    z
-2.0 -1.0  0.162
-2.0 -2.0 -2.838
-2.0 -3.0 -5.838
-1.5 -1.0 -0.682
-1.5 -2.0 -3.682
-1.5 -3.0 -6.682
-1.0 -1.0 -1.268
-1.0 -2.0 -4.268
-1.0 -3.0 -7.268
-0.5 -1.0 -1.542
-0.5 -2.0 -4.542
-0.5 -3.0 -7.542
 0.0 -1.0 -1.586
 0.0 -2.0 -4.586
 0.0 -3.0 -7.586
 0.5 -1.0 -1.631
 0.5 -2.0 -4.631
 0.5 -3.0 -7.631
 1.0 -1.0 -2.000
 1.0 -2.0 -5.000
 1.0 -3.0 -8.000
0,0(0 оценок)
Ответ:
Vadim55554
Vadim55554
08.04.2020 02:16
Поймите и затем запомните "один раз и навсегда", как решаются подобные задачи.
110₂ = 1×2²+1×2¹+0×2⁰ = 4+2 = 6₁₀
А теперь посмотрим на картинку во вложении.
Три младших разряда, дающие требуемые 110₂, мы не трогаем. А в старшие разряды начинаем добавлять по +1, получая из 000 значения 001, 010, 011...
А это ни что иное, как числа 0, 1, 2, ... но только с четвертого бита, а не с первого, поэтому они будут множителями числа 2³ = 8. И будем получать последовательно 0, 8, 16, ... Остается только прибавлять к ним наше исходное 6, получая ряд 6, 14, 22, ...

Долго? Но это из-за разъяснения.
А вот пример. Пусть нам надо найти числа, не превышающие 31, такие, что  в трех младших разрядах будет 101₂. Как решить?
101₂ = 5. Три бита заняты, счетчик пойдет с четвертого, давая множители 2³=8. Получаем ряд 5, 8+5=13, 2×8+5=21, 3×8+5=29.

Еще пример. Пусть теперь в младших разрядах записано 1010, а границей будет 45.
1010₂ = 10₁₀. Занято 4 разряда, поэтому счетчик пойдет с пятого, порождая множители кратные 2⁴ = 16. Получаем 10, 16+10=26, 2×16+10=42, ...
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота