В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
oksa19
oksa19
10.11.2022 20:48 •  Информатика

Дана строка, написать программу, которая находит максимальное простое число (числа отделены пробелами) в строке и заменяет на него все слова, где есть цифры

Показать ответ
Ответ:
Sasha670000
Sasha670000
13.01.2023 10:25
Program rtr1;Uses crt;var a,s,d,e:integer;    ss,dd,ee:string;beginclrscr;Writeln('Введите число от 100 до 399');readln(a);s:=a div 100;e:=a  mod 100 mod 10;d:=a div 10 mod 10;case s of1: ss:='сто';2: ss:='двести';3: ss:='триста';end;case d of2: dd:='двадцать';3: dd:='тридцать';4: dd:='сорок';5: dd:='пятьдесят';6: dd:='шестьдесят';7: dd:='семьдесят';8: dd:='восемьдесят';9: dd:='девяносто';end;case e of1: ee:='один';2: ee:='два';3: ee:='три';4: ee:='четыре';5: ee:='пять';6: ee:='шесть';7: ee:='семь';8: ee:='восемь';9: ee:='девять';end;if d=1 then begin   case e of   1: dd:='одинадцать';   2: dd:='двенадцать';   3: dd:='тринадцать';   4: dd:='четырнадцать';   5: dd:='пятнадцать';   6: dd:='шестнадцать';   7: dd:='семнадцать';   8: dd:='восемнадцать';   9: dd:='девятнадцать';   end;write(ss,' ',dd);end elsewrite(ss,' ',dd,' ',ee);

end.
0,0(0 оценок)
Ответ:
pavy1980
pavy1980
14.02.2022 04:26

string a;

string b;

int count = 0;

int count2 = 0;

bool g = false;

bool g2 = false;

Console.WriteLine("Введите первую строку");

a = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первую строку");

b = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первый символ");

Макрой avatar

char first_symbol = Convert.ToChar(Console.ReadLine());

Console.WriteLine("Введите последний символ");

char second_symbol = Convert.ToChar(Console.ReadLine());

char[] separ = { ' ' };

string[] a1 = a.Split(separ);

string[] b1 = b.Split(separ);

Макрой avatar

for (int i = 0; i < a1.Length; i++)

if (a1[i].IndexOf(first_symbol) == 0 && a1[i].IndexOf(second_symbol) == a1[i].Length - 1)

{

Console.Write(a1[i]+";"); count++; g= true;

}

if (g)

{

Console.WriteLine(" В этой строке :" + count + " слов(о)");

}

Console.WriteLine();

Макрой avatar

for (int i = 0; i < b1.Length; i++)

if (b1[i].IndexOf(first_symbol) == 0 && b1[i].IndexOf(second_symbol) == b1[i].Length - 1)

{

Console.Write(b1[i]+";"); count2++; g2 = true;

}

if (g2)

{

Console.WriteLine(" В этой строке :" + count2 + " слов(о)");

}

Console.ReadLine();

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота