В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2566409
2566409
05.06.2020 15:31 •  Информатика

Дана строка, состоящая только из символов «а» и «б». составьте программу для машины тьюринга, которая переставляет последний символ в начало строки. каретка находится над первым символом строки.

Показать ответ
Ответ:
lis316721
lis316721
11.05.2020 22:45
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var m:=ReadInteger('Количество элементов в массиве А (m):');
  var n:=ReadInteger('Количество элементов в массиве B (n):');
  var k:=ReadInteger('Позиция вставки k (1<k<m):');
  if (k>1) and (k<m) then begin
    var a:=ArrRandom(m,1,99); Writeln('Массив A'); a.Println;
    var b:=ArrRandom(n,1,99); Writeln('Массив B'); b.Println;
    Writeln('Результат вставки'); (a[:k]+b+a[k:]).Println
    end
  else Writeln('Вы нарушили условие 1<k<m')
end.

Тестовое решение
Количество элементов в массиве А (m): 10
Количество элементов в массиве B (n): 6
Позиция вставки k (1<k<m): 4
Массив A
68 64 30 75 36 15 50 39 92 26
Массив B
56 68 97 30 95 63
Результат вставки
68 64 30 75 56 68 97 30 95 63 36 15 50 39 92 26
0,0(0 оценок)
Ответ:
389648
389648
09.04.2020 06:48
Program smallest;<br /><br />var <br />a,b,c:integer;<br /><br />begin<br /><br />write('введите а: ');<br />readln(a);<br />write('введите b: ');<br />readln(b);<br />write('введите c: ');<br />readln(c);<br /><br />if (a - b) > 0 then <br />begin<br />if (a - c) > 0 then<br />writeln('a - наибольшее!');<br />end;<br /><br />if (b - a) > 0 then<br />begin<br />if (b - c) > 0 then<br />writeln('b - наибольшее!');<br />end;<br /><br />if (c - a) > 0 then<br />begin<br />if (c - b) > 0 then<br />writeln('c - наибольшее!');<br />end;<br /><br />end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота