В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ruslanabbyasov2004
ruslanabbyasov2004
04.05.2023 08:08 •  Информатика

дано целое двухзначное число x составьте программу вычисления суммы и произведения цифр трезначного числа x значение x ввести с клавиатуры

Показать ответ
Ответ:
Mashatry
Mashatry
04.02.2021 14:40

Вариант для числа, с любым количеством цифр:

x = abs(int(input()))

s, pr = 0, 1

while x > 0:

   s += x % 10

   pr *= x % 10

   x //= 10

print(s)

print(pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота