В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
GGWPmen
GGWPmen
11.09.2022 18:08 •  Информатика

Дано целое двузначное число. составить программу которая определяет входит ли в него цифра 4

Показать ответ
Ответ:
smailemail
smailemail
13.06.2020 11:13
На псевдокоде
Алг(a,b,fl)
Арг a,b
Рез fl
ввод(a;b) {где а-это десятки,b-еденицы}
fl:=true
Если (a=4)или(b=4) то fl:=true все
Если fl=true то вывод('есть') иначе вывод('нету')
конец
0,0(0 оценок)
Ответ:
ХарламоваяАня
ХарламоваяАня
13.06.2020 11:13

var

  a:byte;

begin

  write('Введите число '); readln(a);

  if (a div 10 = 4) or (a mod 10 = 4) then

    writeln('В число входит цифра 4')

  else

    writeln('цифра 4 в число не входит');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота