Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Мурочkина
28.08.2020 14:27 •
Информатика
Дано целое положительное трехзначное число n. составить программу ,которая определяет входит ли в него цифра 8.
Показать ответ
Ответ:
Mariya050
06.10.2020 05:19
Var n:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(n);
n:=Abs(n);
if (n div 100 = 8)or((n div 10) mod 10 = 8)or(n mod 10 = 8) then WriteLn('Входит')
else WriteLn('Не входит')
End.
Пример работы программы:
Введите трёхзначное число: 85
Входит
0,0
(0 оценок)
Популярные вопросы: Информатика
troffpolina2003
29.11.2022 12:05
1. Впишите пропущенные слова Робот – это механизм, программируемый по двум или более ступеням . ( ) 2. К какому виду относятся данные роботы? А) ...
Zhuldyzovazarina
14.07.2021 21:06
Сделать задачу на питоне без цикла: Цуценятко Чакі важить 1,5 кг, а цуценятко Черрі - 2,5 кг. З їдаючи одну котлету, кожне цуценятко набирає у вазі 100 г. Через скільки днів Чакі...
СуПерБро123
11.06.2020 03:43
Изучи предложенный программный код и определите порты, к которым подключены Гироскопические датчики. А(2В(1С(3D(4...
aazzziizz
24.11.2022 22:43
Как правильно почистить диск D в ноутбуке чтобы не удалять все...
maiorov27
30.12.2021 22:32
В бейсике. Построить семейство N горизонтально расположенных квадратов заданного размера случайных цветов...
jijafhv4636
01.01.2020 14:26
10. Переведите данное число из 10-чной системы 2-чную систему счисления: 9010=?,...
Vlada0904
05.02.2022 05:47
10000111^2= перевести в ^16 шестиричную. пишите не сразу ответ а с решением...
NeSharitVMatematike
16.01.2023 22:02
1)переведите число 1101001110111101снизу этого числа 2 переведите в восьмеричную систему счисления умоляю поже 2) переведите число 321 снизу 10 в семеричную систему счисления....
Lala090
10.05.2023 09:18
Pythonнеобходимо найти квадрат трехзначного числа оканчивается тремя цифрами, равными этому числу. без ввода данных с клавиатуры...
simakovk9
20.04.2022 23:50
Что это за ошибка? и как её исправить на компе?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Begin
Write('Введите трёхзначное число: ');ReadLn(n);
n:=Abs(n);
if (n div 100 = 8)or((n div 10) mod 10 = 8)or(n mod 10 = 8) then WriteLn('Входит')
else WriteLn('Не входит')
End.
Пример работы программы:
Введите трёхзначное число: 85
Входит