Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
mightwood1337
04.06.2022 00:17 •
Информатика
Дано целое трехзначное число x составьте программу вычисления суммы и произведения цифр трехзначного числа x значения x ввести с клавиатуры
Показать ответ
Ответ:
Umarinavitalevna
07.10.2020 23:22
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=abs(ReadInteger).Tostring.Select(x->x.ToDigit);
writeln('сумма цифр: ',a.Sum);
write('произведение цифр: ',a.Aggregate(Real(1),(x,y)->x*y));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
FantomASS1
24.12.2021 11:57
Как сделать, чтобы глаза котика моргали? паскаль! uses graphabc; begin setwindowsize(600,700); setbrushcolor(clgray); line(120,240,150,40); line(150,40,280,150); line(280,150,120,240);...
Полина3333000999
29.03.2021 18:05
Написать программу, которая выводит на экран 7,14,21,28,35,42,49,56,63,70 Цикл использовать обязательно...
Uzdenova2005jam
17.06.2020 20:22
Доступность, актуальность, полнота, объективность, ясность, полезность- относится квидам информацииинформационные процессысвойства информацииИсточник информации...
тупойученик129
13.01.2023 12:44
1. что понимается под обработкой информации? 2. как называется информация, полученная в результате обработки? 3. из каких этапов состоит процесс передачи информации? 4. какие...
lenka040670
13.01.2023 12:44
Пусть p=мне нравятся уроки информатики; q=мне нравятся уроки . выразите следующие формулы на обычном языке q все решил осталось только эта последняя не понимаю как(...
eviilevii123
13.01.2023 12:44
Как перевести 3,2 мегабайта в биты?...
аладик2
13.01.2023 12:44
Написать программу решения линейного уравнения a*x+b=с,где a не равно 0. имя входного файла: lin.in имя выходного файла lin.out формат входных данных: во входном файле находится...
16120000
10.07.2021 01:32
Текстовый редактор представляет собой программу входящую в состав...
5454540
10.07.2021 01:32
Дана квадратная матрица. вывести на экран все четырехзначные числа, у которых сумма двух первых цифр равна сумме двух последних.( например 2754)...
Aslihaaan
10.07.2021 01:32
Вычислите среднее арифметическое двузначных элементов, у которых цифры в числе одинаковые....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1627
begin
var a:=abs(ReadInteger).Tostring.Select(x->x.ToDigit);
writeln('сумма цифр: ',a.Sum);
write('произведение цифр: ',a.Aggregate(Real(1),(x,y)->x*y));
end.