В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
irashnytko
irashnytko
26.07.2022 11:27 •  Информатика

Дано четырехзначное число. написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.

Показать ответ
Ответ:
nadia291
nadia291
26.05.2020 03:30

program a1;
var
a,b,c,r:byte; l,k:word;
begin
read(l);
a:=l mod 10;
b:=l div 10 mod 10;
c:= l div 100 mod 10;
r:= l div 1000 mod 10;
k:=c*1000+r*100+a*10+b;
write(k); end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота