Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
снегурочка98
26.11.2022 23:57 •
Информатика
Дано четырехзначное число. написать программу, которая определяет максимальную цифру числа
Показать ответ
Ответ:
konulrzayevaa
03.10.2020 01:34
#include <iostream>
using namespace std;
int main(){
int n;
int max;
cin>>n;
max=0;
for(int i=1;i<5;i++){
if((n%10)>max){
max=n%10;
}
n=n/10;
}
cout<<max;
cin.get();
cin.get();
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
pyataevadasha
11.10.2020 15:42
Меня не было на уроке, учительница домой задала, решить...
marinakomarova
21.08.2021 00:35
Втерминологии сетей tcp/ip маской сети называется двоичное число, определяющее, какая часть ip-адреса узла сети относится к адресу сети, а какая– к адресу самого узла...
nataalferova8
14.02.2023 13:59
Описать методику решения , учитывая возможные трудности при решении. дано натуральное число n. вычислить сумму элементов от 1 до n...
raya323
08.05.2020 22:17
Ищем решения. значение какого выражения больше. 5 в 20 степени или 55 в 10 степени...
infourazyukp092y0
08.05.2020 22:17
(x^2-y^2)^3 представить в виде многочлена....
meduzakoy4kla
08.05.2020 22:17
Подчеркни в каждом предложении главные члены.рядом напиши проверочные слова для безударных гласных.укажи часть слова, для которых ты искал проверку.сверху солнышко...
nozdracheva95
08.05.2020 22:17
ответьте на вопросы.have you got a sense of humour? can you say good jokes...
polinaserdiuk4
24.10.2021 20:32
Как на украинском языке пишется слово бетонный...
kep951
24.10.2021 20:32
Поставить суффикс в слове поддерживает...
margusqw
24.10.2021 20:32
Что из перечисленного не является телом а) чашка б) ветер в) брусок г) асфальт что из перечисленного является веществом? а) дождь б) вода в)свет ? ) звук переведите...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main(){
int n;
int max;
cin>>n;
max=0;
for(int i=1;i<5;i++){
if((n%10)>max){
max=n%10;
}
n=n/10;
}
cout<<max;
cin.get();
cin.get();
return 0;
}