В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kazybek0611
Kazybek0611
26.10.2021 15:49 •  Информатика

Дано число. Написать программу для нахождения: (python) д) суммы нечетных, кратных 7 цифр,
е) первой цифры.

Показать ответ
Ответ:
привет980
привет980
13.03.2023 13:32

6)  a = 9        b = 17

7)  a = 71       b = 189

5)  a = 14       b = 42

Объяснение:

6)

а = 3 + 8 * 4 = 3 + 32 = 35

b = (a // 10) + 14 = 3 + 14 = 17

a = (b % 10) + 2 = 7 + 2 = 9

a = 9       b = 17

7)

a = 1819

b = (a // 100) * 10 + 9 = 18 * 10 + 9 = 180 + 9 = 189

a = (10 * b - a) % 100 = (10 * 189 - 1819) % 100 = (1890 - 1819) % 100 = 71 % 100 = 71

a = 71       b = 189

5)

a = 42

b = 14

a = a // b = 42 // 14 = 3

b = a * b = 3 * 14 = 42

a = b // a = 42 // 3 = 14

a = 14       b = 42

// - целочисленное деление двух чисел, возвращает целочисленный результат деления, отбрасывая дробную часть.

35 / 10 = 3,5

35 // 10 = 3

% - получение остатка от деления, возвращает разность от делимого и произведения целочисленного результата деления на делитель

17 / 10 = 1,7

17 // 10 = 1 (целочисленный результата деления)

остаток = 17 - 1 * 10 = 17 - 10 = 7

17 % 10 = 7

0,0(0 оценок)
Ответ:
Эммикэт
Эммикэт
21.02.2022 05:54

все работает нормально

Объяснение:

ты тут код без отступов дал, мб там что-то не так. внизу код с отступами, который я тестил .

если тебе не нравится что выводит на 1 меньше: нумерация массива не с 1 начинается, а с 0. просто добавляй а res (индекс + 1)

Код:

n, m = map(int, input().split())

a= [list(map(int, input().split())) for i in range(n)]

print(a)

k = int(input())

count = 0

res=[]

for i in a:

   for j in range(len(i)):

       if i[j] == 0:

           count += 1

   if count == k:

       res.append( a.index(i))

       break

   else:

       count = 0

if len(res) == 0:

   print(count)

else:

   print(min(res))

ps: лучше так сделай

k = int(input())

line = 0

for i in a:

   count = 0

   for j in range(len(i)):

       if i[j] == 0:

           count += 1

   if count >= k:

       line = a.index(i) + 1

       break

print(line)


Короче, кодим. Двумерный массив и его размеры даны. легенда: кинотеатр, каждый элемент-место, если е
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота