дано два массива. для каждого элемента второго массива определите, сколько раз он встречается в первом массиве.
входные данные
первая строка входных данных содержит одно число n (1 ≤ n ≤ 105) – количество элементов в первом массиве. далее идет n целых чисел, не превосходящих по модулю 109 – элементы первого массива, далее идет количество элементов m во втором массиве и m элементов второго массива с такими же ограничениями.
выходные данные
выведите m чисел: для каждого элемента второго массива выведите, сколько раз такое значение встречается в первом массиве.
примеры
входные данные
3
1 2 1
4
0 1 2 3
выходные данные
0 2 1 0
о каляска не бей я тоже хочу в этом году в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что это за что извиняетесь я не могу найти в интернете и слушайте как я красиво пою ты на работе хорошо я поняла что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это
Объяснение:
о каляска не бей а ты как я красиво пою ты мне прислал а вам не нужно будет сделать благодаря разных записей в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что ты вообще не отправляешь задания на проектирование
Var
x: integer; chas: real; str1, str2: string;
Begin
Write('Введите длительность телепрограммы (мин): ');
Readln(X);
Writeln();
if (x < 60) then
begin
if (x < 10) then
Writeln('Миша ляжет спать в 00:0', x)
else
Writeln('Миша ляжет спать в 00:', x)
end
else
begin
chas := x div 60;
x := x mod 60;
if (chas >= 24) then
Writeln('Сегодня Миша спать не ляжет')
else
begin
if (chas < 10) then
str1 := '0' + chas
else
str1 := '' + chas;
if (x < 10) then
str2 := '0' + x
else
str2 := '' + x;
Writeln('Миша ляжет спать в ', str1, ':', str2);
end;
end;
End.