В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
POMOGIf
POMOGIf
14.12.2021 18:03 •  Информатика

Дано два натуральных числа а и в. напишите программу, которая находит цифру, на которую заканчивается число а в степени b (ab).

Показать ответ
Ответ:
ktoto215
ktoto215
05.08.2020 09:21
C++

#include <cmath>

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL,"RUS");

  unsigned long a,b;

   cout<<"Введите число а"<<endl;

   cin>>a;

   cout<<"Введите число b"<<endl;

   cin>>b;

   cout<<((unsigned long)pow(a,b))%10;

   system("pause");

   return 0;

}

C#

using System;

class Power {

 static int Main() {

   ulong a, b;

   Console.WriteLine("Введите число а");

   a=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine("Введите число b");

   b=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine(Math.Pow(a,b)%10);

   Console.ReadKey();

   return 0;

 }

}

Pascal

program Power;

uses crt;

var

a,b,c:Int64;

i:byte;

begin

 writeln ('Введите число a');

 readln(a);

 writeln ('Введите число b');

 readln(b);

 

 c:=1;

 for i:=1 to b do

 c:=c*a;

 

 writeln (c mod 10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота