Дано двухмерных массив размерности m x n. Составить программу нахождения суммы вiдьемних элементов массива. Входной массив и исчисленную сумму вывести на экран. Считать m = 2, n = 5. Программу составить на языке программирования С ++.
Задача №1 var a:array[1..4, 1..5] of integer; i,j,k:integer; begin writeln('Заполните матрицу'); for i:=1 to 4 do for j:=1 to 5 do begin read(a[i,j]); if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; end; writeln('Сумма элементов кратных 3-м и > 20 = ',k); end.
Задача №2 var a:array[1..5, 1..5] of integer; i,j,k:integer; begin writeln('Заполните матрицу'); for i:=1 to 5 do for j:=1 to 5 do begin read(a[i,j]); if i=j then k:=k+a[i,j]; end; writeln('Сумма элементов главной диагонали = ',k); end.
Не самый рациональный метод решения, но как говорится чем смог тем
var a,b,c,x,kc,kn,k1,k2:integer; begin kc:=1; kn:=1; k1:=0; k2:=0; a:=0; b:=0; writeln('Введите число x'); read(x); while x>0 do begin c:=x mod 10; if c mod 2=0 then begin inc(k1); a:=a+c*kc; kc:=kc*10; end; if c mod 2<>0 then begin inc(k2); b:=b+c*kn; kn:=kn*10; end; x:=x div 10; end; if k1>k2 then writeln('Четных больше нечетных') else if k1=k2 then writeln('Количество четных = количеству нечетных') else writeln('Четных меньше нечетных'); writeln(a,' ', b); end.
var a:array[1..4, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 4 do
for j:=1 to 5 do begin
read(a[i,j]);
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j];
end;
writeln('Сумма элементов кратных 3-м и > 20 = ',k);
end.
Задача №2
var a:array[1..5, 1..5] of integer;
i,j,k:integer;
begin
writeln('Заполните матрицу');
for i:=1 to 5 do
for j:=1 to 5 do begin
read(a[i,j]);
if i=j then k:=k+a[i,j];
end;
writeln('Сумма элементов главной диагонали = ',k);
end.
var a,b,c,x,kc,kn,k1,k2:integer;
begin
kc:=1;
kn:=1;
k1:=0;
k2:=0;
a:=0;
b:=0;
writeln('Введите число x');
read(x);
while x>0 do begin
c:=x mod 10;
if c mod 2=0 then begin
inc(k1);
a:=a+c*kc;
kc:=kc*10;
end;
if c mod 2<>0 then begin
inc(k2);
b:=b+c*kn;
kn:=kn*10;
end;
x:=x div 10;
end;
if k1>k2 then writeln('Четных больше нечетных') else if k1=k2 then writeln('Количество четных = количеству нечетных') else writeln('Четных меньше нечетных');
writeln(a,' ', b);
end.