В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
84737263748
84737263748
28.04.2023 15:44 •  Информатика

Дано натуральное число m. написать программу для вычисления суммы вида: 45+42+39++m. входные данные n=38 выходные данные 126

Показать ответ
Ответ:
айлина2хх
айлина2хх
14.06.2020 11:46

Begin

Read(a);

Sum:=45;

I:=45;

While i>a do

Begin

I:=i-3;

Sum:=sum+i;

End;

Write(sum);

End.

Объяснение:

0,0(0 оценок)
Ответ:
Rianariana2002
Rianariana2002
14.06.2020 11:46

Ну, вот на Pascal написал. Вроде так...

var  

Sum, I : integer;

Sum := 0;

I := 45;

While I >= M do

begin

Sum := Sum + I;

I := I - 3;

end;

Writeln(Sum);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота