В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anna26102015
anna26102015
25.04.2023 02:52 •  Информатика

Дано натуральное число n. напишите программу, выводящую все числа квадраты которых меньше n​

Показать ответ
Ответ:
msyesta
msyesta
23.10.2022 21:49
1. Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которой также могут встречаться следующие символы. Символ «?» (вопросительный знак) означает ровно один произвольный символ. Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность. В каталоге находятся 5 файлов: fort.docx; ford.docx; lord.doc; orsk.dat; port.doc. Определите, по какой из масок из них будет отобрана указанная группа файлов: 
fort.docx; ford.docx; lord.doc; port.doc. 
1) *o?*.d?* 
2) ?o*?.d* 
3) *or*.doc? 
4) ?or?.doc? 
0,0(0 оценок)
Ответ:
даник293
даник293
17.11.2021 14:31
#include <iostream>
 #include <sstream>
 #include <vector>
 #include <string>
 using namespace std;

  int main(int argc, char** argv) {

    cout << "string:  "; 
    string s;     getline(cin, s);
    istringstream ss(s);
    vector<string> v; 
    while (ss >> s) v.push_back(s);
    int j=v[0].size(),k=0;
    for (int i=1; i<v.size(); i++)
    if  (v[i].size()>j)   {  j=v[i].size();   k=i; } 
   cout<<"long word:  "<<v[k]<<endl<<endl;
   system("pause");
   return 0;
 }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота