Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
79268888397p06sqw
02.04.2020 21:53 •
Информатика
Дано натуральное число n. составьте программу, которая выводит все числа от 1 по n, у которых последняя цифра кратная 3
Показать ответ
Ответ:
ХранительТьмы228
05.10.2020 10:19
Program n1;
var n,p,i: integer;
begin
write('введите n: ');
readln(n);
for i:=1 to n do
begin
p:= i mod 10;
if (p mod 3=0) and (p<>0)
then write(i,' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
katyasvk
28.10.2020 20:56
Доменным именем компьютера может быть выберите один ответ: a. 123.255.0.12 b. c. [email protected] d. abcd.egwert.com...
dehezy
28.10.2020 20:56
Turbo pascal напишите программу, которая в заданной матрице заменяет все положительные элементы нулями, если количество отрицательных элементов окажется больше, чем...
Emmaff
28.10.2020 20:56
Нарисуй фигуру и заполни алгоритм 1.начало 2.. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12. 13.конец...
Сашунязайка
07.09.2021 22:03
Задание №2. Определите элемент с наибольшей атомной массой, используя функцию MAX. Определите элемент с самой минимальной температурой плавления, используя функцию...
dimanyapr
07.09.2022 22:19
Разместите членов семьи Ивановых в генсалогическом древс, используя следующую информацию: Отца Олега зовут Пётр. У Петра ссть брат Павел. Племянника Павла зовут Виктор....
volchica232005
20.10.2020 04:23
Даны длины 3-х отрезков. Определить, какой треугольник можно сложить. Равносторонний, равнобедренный или обычный? Паскаль...
01061969
01.02.2023 19:58
В некоторой стране автомобильный номер состоит из четырёх цифр и трех букв. Известно что используются буквы от G до V, и цифры от 0 до 9. Вопрос :какое кол во байт...
deniskin278
30.08.2021 16:38
Складіть блок-схему фрагмента алгоритму з вкладеними розгалуженнями, з яких зовнішнє є неповним, а внутрішнє повне , очень нужно...
ayvazova2010
27.03.2022 03:58
Створіть програму, яка порахує відстань, яку Ви проїдете за даним часом і швидкістю руху. Ввести час та швидкість Здійснити обрахункиВивести на екран(Python)...
juter
19.03.2021 08:32
Заполнить матрицу случайными числами. отобразить симметрично относительно вертикальной оси сектора матрицы, которые лежат влево и вправо от главной и боковой диагоналей....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n,p,i: integer;
begin
write('введите n: ');
readln(n);
for i:=1 to n do
begin
p:= i mod 10;
if (p mod 3=0) and (p<>0)
then write(i,' ');
end;
end.