В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Depaer
Depaer
22.12.2020 00:30 •  Информатика

Дано натуральное число. Напишите программу, которая выводит его цифры в столбик в обратном порядке. (python)

Показать ответ
Ответ:
мила0770
мила0770
04.04.2022 21:34
Отсортируйте массив по не возрастанию (вместе с индексами) и подсчитайте сумму  s = s+b[i]*(i+1) - индексы от нуля.
Это и будет наименьшее время.

#include <iostream>
#include <cstdlib>
using namespace std;

int main() {
   int n,i,s;
   bool priz=true;
   cin>>n;
   int b[n],c[n];
   for (int i=0; i<n; i++)
   { 
       cin>>b[i];
       c[i]=i+1;
   }  
// сортировка масcива по не возрастанию
   while (priz)
   {
     priz=false;
     for (int i=0; i<n-1; i++)
     {
       if (b[i]<b[i+1])
       {
         swap(b[i],b[i+1]);
         swap(c[i],c[i+1]);              
         priz=true;
       }
     } 
   }
   s=0;
   for (int i=0; i<n; i++)  s+=b[i]*(i+1);
   cout<<s<<endl;
   for (int i=0; i<n; i++)  cout<<c[i]<<" ";
   cout<<endl;
   system("pause");
   return(0);
}

Ввод - вывод:

6
10 21 13 36 41 9
332
5 4 2 3 1 6
0,0(0 оценок)
Ответ:
Hhhhhhhhelppppp
Hhhhhhhhelppppp
28.11.2020 04:55
Часовая стрелка делает полный оборот, т.е. поворачивается на 360° за 12 часов. Следовательно, за 1 час она повернется на 360/12 = 30°, а за Н часов - на 30°×Н.
В часе 60 минут и за это время часовая стрелка повернется, как мы вычислили, на 30°. Тогда за М минут она повернется на 30°×М/60 или на М/2 градусов.
В минуте 60 секунд, а за минуту стрелка повернется на 1/2 градуса. Тогда за секунду она повернется на 1/(2×60) = 1/120 градуса. А за S секунд - соответственно на S/120 градусов.

Окончательно получаем, что за время от полуночи, равное H:M:S, часовая стрелка повернется на 30*H+M/2+S/120 градусов.

Программа на языке Python 3.4.2
h=float(input('H='))
m=float(input('M='))
s=float(input('S='))
print(30*h+m/2+s/120)

Пример выполнения
Python 3.4.3 (v3.4.3:9b73f1c3e601, Feb 24 2015, 22:43:06)
H=5
M=18
S=48
159.4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота