В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Оленка124683
Оленка124683
04.02.2020 18:12 •  Информатика

Дано натуральное число nn. Напишите программу, которая выводит таблицу умножения на nn. Формат входных данных
На вход программе подается натуральное число.

Формат выходных данных
Программа должна вывести таблицу умножения на введеное число.

Показать ответ
Ответ:
Grister555
Grister555
19.01.2020 18:20
1) 144 - это 12². Следующий квадрат - это 13²=169 и из 169 мы никак не получим за 4 вычитания двоек число 144. Поэтому последняя команда - это 1 (возведи в квадрат).
2) Теперь из 2 надо получить 12 не более, чем за 4 команды. Если 2 возвести в квадрат, получим 4 и этого мало, поэтому возведем 4 еще раз в квадрат, получив 16. Два подряд вычитания двоек как раз дадут 12.
3) Решение
1 (возведи в квадрат) - получаем 4
1 (возведи в квадрат) - получаем 16
2 (вычти 2) - получаем 14
2 (вычти 2) - получаем 12
1 (возведи в квадрат) - получаем 144

ответ: 11221
0,0(0 оценок)
Ответ:
Daniyal11111111
Daniyal11111111
01.02.2021 15:49
Программа №1.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, h, s:real;
begin
   writeln('Enter a, b and h');
   readln(a, b, h);
      s:=(0.5*(a+b))*h;
   writeln('Area of the trapezoid=', s);
   readln;
end.

Программа №2.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, s:integer;
begin
   writeln('Enter the price and quantity');
   readln(a, b);
      s:=a*b;
   writeln('Cost of purchase=', s);
   readln;
end.

Программа №3.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, w:real;
begin
   writeln('Enter the speed and time');
   readln(a, b);
      w:=a*b;
   writeln('Way=', w);
   readln;
end.


Вместо "НАЗВАНИЯ ПРОГРАММЫ" напишите название Вашей программы.
Так как в некоторых задачах не оговорено, что числа целые или нет, я выбрал на всякий случай вещественный(real).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота