В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Bibi123456
Bibi123456
16.03.2022 18:48 •  Информатика

Дано натуральное n. Вычислить: 1/1^1 + 1/2^2 + ... + 1/n^n. составить программу в делфи,мат.модель и алгоритм

Показать ответ
Ответ:
ibarabol318
ibarabol318
19.03.2021 18:35
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=3;
 const int m=3;
 int ma[n][m];
 int c;
 cout<<"First matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   {ma[i][j]=i+j;
   cout<<ma[i][j]<<" ";}
  cout<<endl;}
 for(int i=0;i<n/2;i++){
  for(int j=0;j<m;j++)
   {c=ma[i][j];
   ma[i][j]=ma[n-i-1][j];
   ma[n-1-i][j]=c;}}
 cout<<"Final matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   cout<<ma[i][j]<<" ";
  cout<<endl;}
 return 0;
}

Пример работы программы(n=3,m=3):
First matrix:
0 1 2
1 2 3
2 3 4
Final matrix:
2 3 4
1 2 3
0 1 2
0,0(0 оценок)
Ответ:
nikin25
nikin25
05.10.2020 19:11

 Var i:integer;

begin

for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

end.

 

{While}

Var i:integer;

begin

 i:=100;

while i<=999 do begin

if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' '); inc(i); end;

end.

 

 

 {Repeat}

Var i:integer;

 begin

i:=100; 

repeat

begin

 if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

inc(i); end; 

until i<1000;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота